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BlackBerry Professional Software overview

The BlackBerry® Professional Software is designed for organizations with up to 30 BlackBerry device users who collaborate using the
organization’s messaging server. From their BlackBerry devices, users can send and receive email messages, manage calendar and address
book contacts, and organize their workloads using tasks and memos. Users can also browse the Internet or work with applications that
are available for their BlackBerry devices.

The BlackBerry Professional Software has been designed to streamline administration, with a simplified BlackBerry Manager to help you
set up and manage user accounts and administer the BlackBerry Professional Software. The design is intended to make it easier for
administrators in small organizations to manage the BlackBerry Professional Software in addition to their main responsibilities.

You can install the BlackBerry Professional Software on your messaging server or on a separate server. Installing the BlackBerry Professional
Software and adding your first user account usually takes less than two hours.

If the number of BlackBerry device users in your organization increases, or if you find that users need access to more data or to a broader

range of applications, you can upgrade from the BlackBerry Professional Software to BlackBerry® Enterprise Server Version 4.1 SP5 or
later.

The BlackBerry® Professional Software components are designed to perform the following actions:
« provide productivity tools and data from your organization's applications to your BlackBerry device users
< monitor other BlackBerry Professional Software components
* process, route, compress, and encrypt data
e communicate with the wireless network
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BlackBerry Attachment Service

BlackBerry Configuration Database

BlackBerry Controller

The BlackBerry Attachment Service converts supported message attachments into a format
that users can view on their BlackBerry devices.

The BlackBerry Configuration Database is a relational database that contains configuration
information that the components of the BlackBerry Professional Software use. The
BlackBerry Configuration Database stores the following information:

« information about the connection from the BlackBerry Professional Software to
the wireless network

o user list

 address mappings between PINs and email addresses for BlackBerry® MDS
Connection Service push features

- read-only copy of the master encryption key for each BlackBerry device

The BlackBerry Controller monitors the components of the BlackBerry Professional
Software and restarts them if they stop responding.



Component
BlackBerry Dispatcher

BlackBerry Manager

BlackBerry Messaging Agent

BlackBerry Policy Service

BlackBerry Router

BlackBerry Synchronization Service

messaging server
user computer with the BlackBerry Device
Manager

Description

The BlackBerry Dispatcher compresses and encrypts the data that it sends to and receives
from BlackBerry devices. It sends the data through the BlackBerry Router to and from the
wireless network.

The BlackBerry Manager connects to the BlackBerry Configuration Database. You use the
BlackBerry Manager to manage user accounts and BlackBerry devices.
The BlackBerry Messaging Agent connects to the messaging server to provide services for
messaging, calendar management, address lookup, attachment viewing, and wireless
generation of encryption keys. The BlackBerry Messaging Agent also acts as a gateway for
the BlackBerry Synchronization Service to access organizer data on the messaging server.
In a Microsoft® Exchange messaging environment, the BlackBerry Messaging Agent also
synchronizes configuration data between the BlackBerry Configuration Database and user
mailboxes.
The BlackBerry Policy Service performs administration services over the wireless network,
such as sending IT policies and IT administration commands and provisioning service books.
IT policies and IT administration commands define BlackBerry device security, settings for
wireless data synchronization, and other configuration settings on the BlackBerry device.
Service books define feature and component settings on the BlackBerry device.
The BlackBerry Router connects to the wireless network to send data to and receive data
from BlackBerry devices. It also sends data within your organization's network to
BlackBerry devices that are connected to computers using the BlackBerry® Device
Manager.
The BlackBerry Synchronization Service synchronizes organizer data between BlackBerry
devices and the messaging server over the wireless network.
The messaging server stores email accounts.
The user computer with the BlackBerry Device Manager enables users to connect their
BlackBerry devices to their computers using a serial connection or USB connection. The
BlackBerry Professional Software uses this connection to send data to and receive data from
BlackBerry devices.

Data traffic from BlackBerry devices bypasses the wireless network while a BlackBerry
device is connected to a user’s computer. The BlackBerry Device Manager connects to the
BlackBerry Router, which sends data directly to the BlackBerry device.

Users can install the BlackBerry Device Manager separately or with the BlackBerry®
Desktop Manager as part of the full BlackBerry® Desktop Software installation. The
BlackBerry Device Manager is an optional component, but the BlackBerry Router requires
it to support connections to the BlackBerry Router that bypass the BlackBerry®
Infrastructure.

The BlackBerry® Professional Software components are designed to perform the following actions:



 provide productivity tools and data from your organization's applications to your BlackBerry device users
» monitor other BlackBerry Professional Software components

 process, route, compress, and encrypt data

e communicate with the wireless network
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BlackBerry Attachment Service

BlackBerry Configuration Database

The BlackBerry Attachment Service converts supported message attachments into a format
that users can view on their BlackBerry devices.
The BlackBerry Configuration Database is a relational database that contains configuration
information that the components of the BlackBerry Professional Software use. The
BlackBerry Configuration Database stores the following information:
« details about the connection from the BlackBerry Professional Software to the
wireless network

e user list



Component

BlackBerry Controller

BlackBerry Dispatcher

BlackBerry Manager

BlackBerry Messaging Agent

BlackBerry Policy Service

BlackBerry profiles database

BlackBerry Router

BlackBerry state databases

BlackBerry Synchronization Service

messaging server
user computer with the BlackBerry Device
Manager

Description

« address mappings between PINs and email addresses for BlackBerry® MDS
Connection Service push features

- read-only copy of the master encryption key for each BlackBerry device

The BlackBerry Controller monitors the components of the BlackBerry Professional
Software and restarts them if they stop responding.

The BlackBerry Dispatcher compresses and encrypts the data that it sends to and receives
from BlackBerry devices. It sends the data through the BlackBerry Router to and from the
wireless network.

The BlackBerry Manager connects to the BlackBerry Configuration Database. You use the
BlackBerry Manager to manage user accounts and BlackBerry devices.

The BlackBerry Messaging Agent connects to the messaging server to provide services for
messaging, calendar management, address lookups, attachment viewing, and generation
of wireless encryption keys. The BlackBerry Messaging Agent also acts as a gateway for the
BlackBerry Synchronization Service to access organizer data on the messaging server. The
BlackBerry Messaging Agent synchronizes configuration data between the BlackBerry
Configuration Database and the BlackBerry profiles database.

The BlackBerry Policy Service performs administration services over the wireless network,
suchas sending IT policies and IT administration commands, and provisioning service books.
IT policies and IT administration commands define BlackBerry device security, settings for
wireless data synchronization, and other configuration settings on the BlackBerry device.
Service books are also used to define settings on the BlackBerry device.

The BlackBerry profiles database is an IBM® Lotus® Domino® database that contains
configuration information for user accounts.

The BlackBerry Router connects to the wireless network to send data to and receive data
from the BlackBerry device. It also sends data within your organization's network to
BlackBerry devices that are connected to computers using the BlackBerry® Device
Manager.

The BlackBerry state databases contain information that link messages sent from or received
on a BlackBerry device to corresponding messages in the email application on users'
computers. The information in the BlackBerry state databases is designed to support
features such as email reconciliation, message forwarding, message filing, and replying with
text.

The BlackBerry Synchronization Service synchronizes organizer data between a
BlackBerry device and the messaging server over the wireless network.

The messaging server stores email accounts.

The user computer with the BlackBerry Device Manager enables users to connect their
BlackBerry devices to their computers using a serial connection or USB connection. The
BlackBerry Professional Software uses this connection to send data to and receive data from
BlackBerry devices.

Data traffic from BlackBerry devices bypasses the wireless network while a BlackBerry
device is connected to a user’s computer. The BlackBerry Device Manager connects to the
BlackBerry Router, which sends data directly to the BlackBerry device.



Component Description
Users caninstall the BlackBerry Device Manager separately or with the BlackBerry® Desktop

Manager as part of the full BlackBerry® Desktop Software installation. The BlackBerry
Device Manager is an optional component, but the BlackBerry Router requires it to support
connections to the BlackBerry Router that bypass the BlackBerry® Infrastructure.



System requirements

You can install the BlackBerry® Professional Software on the server that hosts your messaging server or on a separate host server.

If you might upgrade to the BlackBerry® Enterprise Server in the future, consider installing the BlackBerry Professional Software on a
separate host server. Installation of the BlackBerry Enterprise Server on the messaging server is not a supported environment.

The setup application can automatically install a Microsoft® SQL Server™ 2005 Express database engine, or you can configure the
BlackBerry Professional Software to connect to a remote Microsoft SQL Server database engine.

Before installing the BlackBerry Professional Software, the setup application runs a preinstallation tool that verifies that your environment
meets the minimum system requirements for the BlackBerry Professional Software. The tool displays the results of the analysis on the
screen.

It also writes the results in the log files in the following location: <drive>\Program Files\Research In Motion\Blackberry Enterprise Server
\Logs\Installer

The file name begins with Detectionlog_ .

Item Requirement

hardware To support the BlackBerry® Professional Software installed on a separate host server, with
Microsoft® SQL Server™ 2005 Express installed by the setup application on the same server,
at a minimum, you require the following hardware:

* Intel® Pentium® IV processor (1.5 GHz or more)
» 1GB or more of available RAM

To support the BlackBerry Professional Software installed on the messaging server, with
Microsoft SQL Server 2005 Express installed by the setup application on the same server,
at a minimum, you require the following hardware for the BlackBerry Professional
Software:

* IntelPentium IV processor (2 GHz or more)
1.5 GB or more of available RAM

operating system On the host server for the BlackBerry Professional Software, install one of the following
operating systems in English, French, German, Italian, or Spanish:

* Microsoft® Windows Server® 2000 SP4

 Microsoft Windows Server 2003 SP1 or SP2

« Microsoft Windows Server 2003 (64-bit)

 Microsoft Windows Small Business Server (Standard or Premium edition)
 Microsoft Windows Small Business Server SP2



Item
messaging server

messaging server administration tool

web browser
CDO library

data access com ponents

database management system

Microsoft® .NET Framework

Requirement
Install one of the following messaging servers with all Daylight Saving Time patches:
 Microsoft Exchange Version 5.5 native environment
* Microsoft Exchange 2000 native environment
» Microsoft Exchange 2003 native environment
» Microsoft Exchange 2007 native environment with public folders set up

 mixed environment (any combination of Microsoft Exchange Version 5.5, Microsoft
Exchange 2000, Microsoft Exchange 2003, and Microsoft Exchange 2007)

Ina Microsoft Exchange Version 5.5, Microsoft Exchange 2000, or Microsoft Exchange 2003
messaging environment, install one of the following administration tools on the host server
for the BlackBerry Professional Software:

e Microsoft Exchange 5.5 Administrator
» Microsoft Exchange 2000 System Manager
* Microsoft Exchange 2003 System Manager

In a Microsoft Exchange 2007 messaging environment, install one of the following
administration tools on the host server for the BlackBerry Professional Software:
* Microsoft Exchange 2003 SP2 with System Tools

* Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 (for
more information, visit http://support.microsoft.com/kb/929590 to read
KB929590)

Install Microsoft® Internet Explorer Version 6.0 with Java® or JavaScript® turned on and
the language preferences configured to display encoded web pages.

Install the latest version that is supported by the version of Microsoft Exchange in your
environment.

Install one of the following data access components on the host servers for the BlackBerry
Professional Software and the BlackBerry Configuration Database:

 Microsoft Data Access Component (MDAC) Version 2.8 with Security Patch
MS04-003 (Version 2000.85.1025.00)

» MDAC Version 2.8 SP2 (Version 2000.86.1830.00)

Install one of the following database management systems, running on the Local System
account, if applicable:

* local MicrosoftSQL Server 2005 Express (you can install this database engine
during the installation of the BlackBerry Professional Software)

« local MicrosoftSQL Server 2000 Desktop Engine (MSDE 2000)
» remote MicrosoftSQL Server 2000 SP3

 remote MicrosoftSQL Server 2005 (Standard or Enterprise)
 remote MicrosoftSQL Server 2005 (64-bit)

You require Microsoft .NET Framework Version 1.1 SP1. If this is not present, it is installed
as part of the installation process.



Item Requirement

virtual environment (optional) You can use VMware® ESX Server Version 2.5.2 to isolate the BlackBerry Professional
Software when it is installed on the same server as your messaging server or to isolate the
BlackBerry Professional Software from other applications on a server.

network environment settings Configure your organization's firewall or proxy to meet the following conditions:

« firewall settings permit the host server for the BlackBerry Professional Software to
initiate a two-way TCP/IP connection to an external server on port 3101

« corporate firewall can resolve Internet addresses using the DNS
 proxy is transparent, if you are using a proxying firewall

System requirements: Client computers in a Microsoft Exchange messaging
environment

Item Requirement
email client software Your email client software must be one of the following:
» Microsoft® Outlook® 2000
* Microsoft Outlook 2003
* Microsoft Outlook 2003 SP2
« Microsoft Outlook 2007

System requirements: BlackBerry Professional Software in an IBM Lotus Domino
messaging environment

Item Requirement

hardware To support the BlackBerry® Professional Software installed on a separate host server, with
Microsoft® SQL Server™ 2005 Express installed by the setup application on the same server,
at a minimum, you require the following hardware:

* Intel® Pentium® IV processor (1.5 GHz or more)
» 1GB or more of available RAM

To support the BlackBerry Professional Software installed on the messaging server, with
Microsoft SQL Server 2005 Express installed by the setup application on the same server,
ata minimum, you require the following hardware for the BlackBerry Professional
Software:

* IntelPentium IV processor (2 GHz or more)

* 1.5 GB or more of available RAM




Item
operating system

messaging server

web browser

notes.ini file

data access com ponents

database management system

Microsoft .NET Framework

Requirement

On the host server for the BlackBerry Professional Software, install one of the following
operating systems in English, French, German, Italian, or Spanish:

 Microsoft® Windows Server® 2000 SP4
 Microsoft Windows Server 2003 SP1 or SP2
 Microsoft Windows Server 2003 (64-bit)
Install one of the following messaging servers with all Daylight Saving Time patches:
» IBM® Lotus® Domino® Version 6.5.5
e |BM Lotus Domino Version 7.0.0
* IBM Lotus Domino Version 7.0.1
 IBM Lotus Domino Version 7.0.2
* IBM Lotus Domino Version 8.0.0

Your messaging server must meet the following additional requirements:
* ltisinstalled as a member of the LocalDomainServers group.
* It has permission to run agents.
« It has manager-level access to the mail files of BlackBerry device users.

Install Microsoft® Internet Explorer Version 6.0 with Java® or JavaScript® turned on and
the language preferences configured to display encoded web pages.
Configure the following conditions in the notes.ini file:

 read/write permissions

e SERVERKEYFILENAME value set to server.id name only, without full path
information

Install one of the following data access components on the host servers for the BlackBerry
Professional Software and the BlackBerry Configuration Database:

* Microsoft Data Access Component (MDAC) Version 2.8 with Security Patch
MS04-003 (Version 2000.85.1025.00)

» MDAC Version 2.8 SP2 (Version 2000.86.1830.00)

Install one of the following database management systems, running on the Local System
account, if applicable:

* local MicrosoftSQL Server 2005 Express (you can install this database engine
during the installation of the BlackBerry Professional Software)

« local MicrosoftSQL Server 2000 Desktop Engine (MSDE 2000)
» remote MicrosoftSQL Server 2000 SP3

 remote MicrosoftSQL Server 2005 (Standard or Enterprise)
 remote MicrosoftSQL Server 2005 (64-bit)

You require Microsoft .NET Framework Version 1.1 SP1. If this is not present, it is installed
as part of the installation process.



Item Requirement

virtual environment (optional) You can use VMware® ESX Server Version 2.5.2 to isolate the BlackBerry Professional
Software when it is installed on the same computer as your messaging server, or to isolate
the BlackBerry Professional Software from other applications on a server.

network environment settings Configure your organization's firewall or proxy to meet the following conditions:

« firewall settings permit the host server for the BlackBerry Professional Software to
initiate a two-way TCP/IP connection to an external server on port 3101

« corporate firewall can resolve Internet addresses using the DNS
 proxy is transparent, if you are using a proxying firewall

System requirements: Client computers in an IBM Lotus Domino environment

Item
email client software

Requirement

Your email client software must be one of the following:
e IBM® Lotus Notes® Version 5.0.12
« |BM Lotus Notes Version 6.0.4
« |BM Lotus Notes Version 6.5.5
« IBM Lotus Notes Version 7.0.0 or 7.0.1







Configuring a Microsoft Exchange Version 5.5, Microsoft Exchange 2000,
or Microsoft Exchange 2003 messaging environment

To configure a Microsoft® Exchange Version 5.5, Microsoft Exchange 2000, or Microsoft Exchange 2003 messaging environment, perform
the following tasks:

¢ Create a Microsoft® Windows® account and mailbox. The account and mailbox are required so that the components of the
BlackBerry® Professional Software can authenticate to the Microsoft Exchange Server.

» Configure permissions for the Microsoft Windows account. These permissions are required so that the components of the
BlackBerry Professional Software can authenticate to the Microsoft Exchange Server.

 Configure Microsoft Exchange permissions for the Microsoft Windows account. These permissions allow the account to log in to
the local server and run the BlackBerry Professional Software as a Microsoft Windows service.

« Start the MAPI subsystem. This task starts the messaging interface and allows messaging applications to work through a single
Microsoft Exchange application.

« |dentify and address Microsoft Exchange known issues for wireless calendar synchronization.

You create and configure a Microsoft® Windows® account and mailbox in the Microsoft® Active Directory® service to run the BlackBerry®
Professional Software. The components of the BlackBerry Professional Software also use this account to authenticate to the Microsoft®
Exchange messaging server.

You might not be able to see the Microsoft Windows account to verify that it has been created.

1. On the messaging server, on the taskbar, click Start > Administrative Tools > Active Directory Users and Computers.
2. Create an account with the following properties:

* Name: besadmin

« User location: create a Microsoft Exchange mailbox

e Group membership: Domain User

3. Assign this account the Send As permission for all user accounts in the User container of your MicrosoftActive Directory domain.
4. Send a test message to activate the new mailbox.

Note: For more information about the Send As permission, visit www.support.microsoft.com to read article KBO4707. For more information
about assigning the Send As permission for multiple user accounts, visit www.support.microsoft.com to read article KB912918.

Configure the permissions of the Microsoft® Windows® account that you plan to use to install the BlackBerry® Professional Software.

1. On the server that hosts the BlackBerry Professional Software, on the taskbar, click Start > Programs > Administrative Tools >
Local Security Policy.

2. Configure the following permissions for the Microsoft Windows account:


http://www.support.microsoft.com
http://www.support.microsoft.com

 log on locally with local permissions (if not assigned by default)
 log on as a service

3. On the taskbar, click Start > Programs > Administrative Tools > Computer Management.
4. Add the Microsoft Windows account to the local Administrators group.

Configuring Microsoft Exchange permissions for the Microsoft Windows account

Configure Microsoft Exchange Version 5.5 permissions for the Microsoft Windows account

On the server that hosts the BlackBerry® Professional Software, configure the Microsoft® Exchange permissions for the Microsoft®
Windows® account that you plan to use to install the BlackBerry Professional Software.

In the Microsoft Exchange Version 5.5 Administrator, in both the Site and Configuration containers, configure the Service Account Admin
permission.

Configure Microsoft Exchange 2000 or Microsoft Exchange 2003 permissions for the Microsoft
Windows account

On the server that hosts the BlackBerry® Professional Software, configure the Microsoft® Exchange permissions for the Microsoft®
Windows® account that you plan to use to install the BlackBerry Professional Software.

1. In the Microsoft Exchange 2000 or Microsoft Exchange 2003 System Manager, configure the Exchange View Only Administrator
permission with the minimum access level of Administrative Groups.

2. Atthe server level, configure the following permissions:
* SendAs
* Receive As
« Administer Information Store

Start the MAPI subsystem

To start the MAPI subsystem, open the Microsoft® Exchange System Manager.

Identify and address Microsoft Exchange known issues for wireless calendar
synchronization

1. Visit www.support.microsoft.com to read the following Microsoft® Exchange articles:

Microsoft Exchange tool Microsoft article ID

Microsoft Exchange Version 5.5 Administrator . 312273


http://www.support.microsoft.com

818709
Microsoft Exchange 2000 System Manager

314606
824960

Microsoft Exchange 2003 System Manager

823343
894470

2. |dentify the hotfixes that are required for your messaging environment.
3. Download and install the hotfixes on the server that hosts the BlackBerry® Professional Software.






Configuring a Microsoft Exchange 2007 messaging environment

To configure a Microsoft® Exchange 2007 environment, perform the following tasks:

» Create a Microsoft Exchange 2007 account and mailbox. The account and mailbox are required so that the components of the
BlackBerry® Professional Software can authenticate to the Microsoft Exchange Server.

« Configure Microsoft® Windows® permissions for the Microsoft Exchange account. These permissions allow the account to log in
to the local server and run the BlackBerry Professional Software as a Microsoft Windows service.

= Configure Microsoft Exchange 2007 permissions for the Microsoft Exchange account.
« Assign permissions that allow BlackBerry device users to send messages in a Microsoft Exchange 2007 environment.

« If Microsoft Exchange Server 2007 storage group, database, and public folders are not installed, after you install and configure
BlackBerry Professional Software, update the registry on the host server.

Create a Microsoft Exchange 2007 account and mailbox

You create and configure a Microsoft® Exchange account and mailbox to run the BlackBerry® Professional Software. The components of
the BlackBerry Professional Software also use this account to authenticate to the Microsoft® Exchange messaging server.

1. Log in to the Microsoft® Exchange Server as an administrator with the permission to create an account.
2. Open the Microsoft Exchange Management Console.
3. Create a Microsoft Exchange account named besadmin.

Configure Microsoft Windows permissions for the Microsoft Exchange 2007
account

1. On the Microsoft® Exchange Server, right-click My Computer. Click Manage.
2. Inthe left pane, expand Local Users and Groups.

3. Navigate to the Groups folder.

4. Inthe right pane, double-click Administrators.

5. Click Add.

6. In the Enter the object names to select field, type besadmin.

7. Click OK.

8. Click Apply.

9. Click OK.

Configure Microsoft Exchange 2007 permissions for the Microsoft Exchange
account

1. Open the Microsoft® Exchange Management Shell.
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Perform one of the following actions:
« If you are performing the task locally on the Microsoft Exchange Server 2007, type the following command:

add-exchangeadministrator "BESAdmin” -role ViewOnlyAdmin
« If you are performing the task from another computer, type the following command:

set-mailboxserver “<messaging_server_name>" | add-exchangeadministrator “BESAdmin” -role ViewOnlyAdmin
Type the following command:

set-mailboxserver “<messaging_server_name>" | add-adpermission -user "“BESAdmin" -accessrights ExtendedRight -
extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

On the Microsoft® Exchange Server, on the taskbar, click Start > Administrative Tools > Active Directory Users and
Computers.

On the View menu, click Advanced Features.
Right-click the domain root. Click Properties.

On the Security tab, click Advanced.

Click Add.

Type besadmin.

Click Check Name.

Click OK.

In the Apply Onto drop-down list, click User Objects.
In the Allow column, select the Send As check box.

. Click Apply.

Click OK.



Configuring an IBM Lotus Domino messaging environment

To configure an IBM® Lotus® Domino® environment, perform the following tasks:

» Create a group for BlackBerry® Professional Software administrators.

« Configure the server document to allow administrators to move users in the BlackBerry Domain.
 Configure the local system account for Microsoft® Windows® authentication.

e Configure the local system account for database authentication.

Create a group for BlackBerry Professional Software administrators

You must verify that the LocalDomainServers group includes the server on which you plan to install the BlackBerry® Professional
Software.

You must configure the IBM® Lotus® Domino® messaging environment to permit the required database access from the BlackBerry
Professional Software.

Only the users included in the BlackBerryAdmins group can administer and manager the BlackBerry Professional Software.

1. In the administration server directory, create an IBM Lotus Domino group with the following properties:
» Name: BlackBerryAdmins

« Group type: Access Control List only
» Description: users who can add, remove, and change the settings for BlackBerry device users

» Members: LocalDomainServers; any users who might administer the BlackBerry Professional Software

2. On the server that hosts the BlackBerry Professional Software, replicate the group in the IBM Lotus Domino Directory.

Configure the server document to allow administrators to move users in a
BlackBerry Domain

1. Open the server document for the IBM® Lotus® Domino® server on which you plan to install the BlackBerry® Professional

Software.

2. Perform one of the following actions:

« To configure permissions in an IBM Lotus Domino Version 6 or Version 7 environment, in the Run unrestricted methods and
operations field, add the LocalDomainServers group.

» Toconfigure permissionsinan IBM Lotus Domino Version 5 environment, in the Run unrestricted Java/Javascript/COM field,
add the LocalDomainServers group.

21
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Configure the local system account for Microsoft Windows authentication

Perform this task if you want to use a local system account to access the BlackBerry® Professional Software, install the BlackBerry

Configuration Database on another computer, and use Microsoft® Windows® authentication to connect to the BlackBerry Configuration
Database.

In the Microsoft®SQL Server™ Enterprise Manager or in the MicrosoftSQL Server Management Studio, create a new user account with
the following properties:

user name set to the name of the server for the BlackBerry Professional Software, in the following format: <Domain>
\<computer_name>$

authentication method set to Microsoft Windows (trusted) authentication
roles that are required to change the BlackBerry Configuration Database

Configure the local system account for database authentication

. On the server that hosts the BlackBerry® Professional Software, on the taskbar, click Start > Run. Type regedit.

In HKEY_USERS\.DEFAULT\Software\Research In Motion\BlackBerry Enterprise Server\Database, create the following String
values:

« Login: Type the name of the database account that has the required database permissions.
= Password: Type the password for the database account.

3. Close the Registry Editor.



Setting up the database connection

The BlackBerry® Professional Software can connect to the BlackBerry Configuration Database on the Microsoft® SQL Server™ using either
Microsoft® Windows® authentication or database authentication.

If you use Microsoft Windows authentication, the BlackBerry Manager logs in to the BlackBerry Configuration Database using the Microsoft
Windows account that is already logged in to the computer.

If you use database authentication, the BlackBerry Manager authenticates to the BlackBerry Configuration Database using the database
credentials that were configured when the database was set up.

Specifying permissions when connecting to the BlackBerry Configuration
Database using Microsoft Windows authentication

During the BlackBerry® Professional Software installation process, if you choose to connect to the BlackBerry Configuration Database
using Microsoft® Windows® authentication, the Microsoft Windows account that you use must have permissions on the database server.
The type of permission depends on the setup type that you choose and on whether you create the BlackBerry Configuration Database on
the same computer as the BlackBerry Professional Software or on another database server.

Assign MicrosoftSQL Server permissions

Complete this task only if you do not plan to install Microsoft® SQL Server™ 2005 Express during the BlackBerry® Professional
Software installation process. When you select Microsoft® Windows® authentication during the BlackBerry Professional Software
installation process, the setup application automatically assigns the required permissions to the Microsoft Windows account that you used
to start the setup application.

Perform one of the following actions:

« Ifyou create the BlackBerry Configuration Database on the same server as the BlackBerry Professional Software, assign system
administrator permission to the Microsoft Windows account in the BlackBerry Configuration Database.

« If you create the BlackBerry Configuration Database on a separate server, assign server administrator and database creator
permissions to the Microsoft Windows account. If you are using MicrosoftSQL Server Express 2005, also assign the system
administrator permissionto each of the following roles: SQLAgentUserRole, SQLAgentReaderRole,and SQLAgentOperatorRole.

23
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Installing the BlackBerry Professional Software

In the first step of the installation process, the setup application runs a preinstallation tool to verify that your environment meets the
following requirements:

operating system requirements on the host computer for the BlackBerry® Professional Software
messaging server software and environment requirements

network environment requirements

database software and environment requirements

security support requirements

virtual machine requirements, if applicable

multilanguage support requirements, if applicable

You are notified if you must install or update any applications.

Prerequisites: Installing the BlackBerry Professional Software

Item

Requirement

credentials from the BlackBerry® « client access license key, or CAL key
Professional Software installation media

« Server Routing Protocol identifier, or SRP identifier
» SRP authentication key
» SRPaddress

installation credentials from your « name of the host server for the BlackBerry Professional Software
environment

« name of the host server for the messaging server, if the messaging server
application is installed on a separate server

» name of the host server for the BlackBerry Configuration Database, if the
BlackBerry Configuration Database is installed on a separate server

Install the BlackBerry Professional Software in a Microsoft Exchange messaging
environment

Note: During the installation process, you must restart the server that hosts the BlackBerry® Professional Software. The restart can take
several minutes.

1.

Log in to the server that hosts the BlackBerry Professional Software using the besadmin account that you created.

2. Inthe BlackBerry Professional Software installation media, double-click the setup.exe file.
3.
4. Complete the Apache Tomcat™ license agreement. Click Next.

Complete the BlackBerry Professional Software license agreement. Click Next.
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At the Preinstallation Checklist screen, perform one of the following actions:
» To continue, click Next.
 To address requirements identified in the checklist, click Cancel. You can restart the upgrade at a later time.
On the Installation Information screen, type the password for the Microsoft Windows account that runs the BlackBerry Professional

Software and the name of the server that hosts the BlackBerry Professional Software. Record this information. You will require it
to complete the configuration. Click Next.

On the SQL Server Option screen, specify whether you want the setup application to install Microsoft®SQL Server™ 2005 Express
on your server. Click Next.

On the Installation Summary screen, verify the setup information.

9. Click Next to begin the installation.

10.
n

IS

10.
1.
12.

When the installation process completes, click Continue.
When you are prompted to restart the server, click Yes.

. Logintothe server that hosts the BlackBerry® Professional Software using the besadmin account, and wait for the setup application

to restart.

On the Database screen, select whether to install the BlackBerry Configuration Database locally (on the same server as the
BlackBerry Professional Software) or remotely.

Type the name or IP address of the host computer for the database.
Specify the database name.
Specify the port on which the BlackBerry Professional Software connects to the database, or accept the default port (port 1433).
Select one of the following authentication types:
« Ifyou are installing a local database, set the authentication method to Windows (trusted).

- If the BlackBerry Professional Software will connect to a remote database, select the authentication type for that database.

Click Next.

. Ifyou are installing a local database, when you are prompted to create the BESMgmt database, click Yes.

You are notified when the database is successfully created.
On the License Key screen, type the CAL key that you received with your installation package.
On the SRP Setting screen, type the SRP identifier and SRP authentication key that you received with your installation package.
Click Validate SRP Key and ID to confirm the information is correct. Click OK and click Next.
In the Microsoft® Exchange Server window, perform the following actions:
 In the Microsoft Exchange Server field, type the name of your messaging server, if it does not display automatically.
 In the Mailbox field, type the name of the mailbox that you created for your Microsoft® Windows® account.
* Click Check Name to verify the information.



13.

14.
15.

e Click OK.

Select the Start Service check box, if it is not already selected. You are notified as each of the following services starts:
 BlackBerry Controller

 BlackBerry Router

 BlackBerry Dispatcher

« BlackBerry MDS Connection Service

 BlackBerry Policy Service

 BlackBerry Attachment Service

 BlackBerry Synchronization Service

« BlackBerry Alert

Click Finish.

If a MAPI error displays when you start the BlackBerry Manager, perform the following actions:

« On the server that hosts the BlackBerry Professional Software, on the taskbar, click Start > Edit MAPI Profile.
 Verify the Microsoft Exchange Server name and the Microsoft Exchange administrator mailbox.

» Click OK.

If Microsoft® Outlook® with Public Folders was not already installed when you installed Microsoft® Exchange 2007, the Microsoft
Exchange installation application did not automatically install a Public Folder storage group and database, which are required by
BlackBerry® Professional Software. Complete this task if the Public Folders storage group and database are not installed.

1.
2.
3.

n
12.
13.
14.
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On the server that hosts the BlackBerry Professional Software, on the taskbar, click Start > Run.
Type regedit.

Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles
\BlackBerryServer.

Locate the subkey named 00036604.

Right-click the subkey.

Click Modify.

In the Value data, change the second pair of digits to 80.
Click OK.

Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles
\BlackBerryManager.

Locate the subkey named 00036604.

Right-click the subkey.

Click Modify.

In the Value data, change the second pair of digits to 80.
Click OK.



15.

Close the Registry Editor.

Install the BlackBerry Professional Software in an IBM Lotus Domino messaging
environment

Note: During the installation process, you must restart the server that hosts the BlackBerry® Professional Software. The restart can take
several minutes.

1.
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10.

n

12.
13.
14.
15.

Log in to the server that hosts the BlackBerry Professional Software using an administration account with the appropriate database
permissions.

Click Start > Administrative Tools > Services.
Right-click Lotus Domino Server. Click Properties.
Set the Startup type to Manual.
In the Service status section, click Stop.
In the BlackBerry Professional Software installation media, double-click the setup.exe file.
Complete the BlackBerry Professional Software license agreement. Click Next.
Complete the Apache Tomcat™ license agreement. Click Next.
At the Preinstallation Checklist screen, perform one of the following actions:
» To continue, click Next.
 To address requirements identified in the checklist, click Cancel. You can restart the upgrade at a later time.
On the Installation Information screen, type your administration account password and the name of the host server for the
BlackBerry Professional Software. Click Next.

On the SQL Server Option screen, specify whether you want the setup application to install Microsoft®SQL Server™ 2005 Express
on your server. Click Next.

On the Installation Summary screen, verify the setup information.
Click Next to begin the installation.

When the installation process completes, click Continue.

When you are prompted to restart the server, click Yes.

Configure the BlackBerry Professional Software in an IBM Lotus Domino messaging
environment

1.
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Log in to the server that hosts the BlackBerry® Professional Software using the account that you used to start the installation, and
wait for the setup application to restart.

On the Database screen, select whether to install the BlackBerry Configuration Database locally (on the same server as the
BlackBerry Professional Software) or remotely.

Type the name or the IP address of the host computer for the database.

. Specify the database name.

Specify the port on which the BlackBerry Professional Software connects to the database, or accept the default port (port 1433).



6. Select one of the following authentication types:

If you are installing a local database, set the authentication method to Windows (trusted).

If the BlackBerry Professional Software will connect to a remote database, select the authentication type for that database.

7. Click Next.
8. Ifyou are installing a local database, when you are prompted to create the BESMgmt database, click Yes.

You are notified when the database is successfully created.

9. On the License Key screen, type the CAL key that you received with your installation package.

10. On the SRP Setting screen, type the SRP identifier and SRP authentication key that you received with your installation package.
1. Click Validate SRP Key and ID to confirm the information is correct. Click OK and click Next.
12. Select the Start Service check box, if it is not already selected. You are notified as each of the following services starts:

BlackBerry Controller

BlackBerry Router

BlackBerry Dispatcher

BlackBerry MDS Connection Service
BlackBerry Policy Service
BlackBerry Attachment Service
BlackBerry Synchronization Service
BlackBerry Alert

13. Click Finish.
14. On the server that hosts the BlackBerry Professional Software, on the taskbar, click Start > Lotus Domino Server.

15. Click Start Domino as a Windows service.



30



Troubleshooting the installation process

A third-party tool did not install successfully and the BlackBerry Professional
Software setup application closed
Possible solution

1. In the BlackBerry® Professional Software installation media, double-click the Tools folder.

2. Double-click the setup application file for the tool.

3. Complete the instructions on the screen.

4. Restart the BlackBerry Professional Software setup application.

"Failed to write License Key to the Database"

When you try to add the CAL key, the following message appears:""Failed to write License Key to the Database.""

Possible solution

After you restart the server during the BlackBerry® Professional Software installation process, you must log in using the same Microsoft®
Windows® account that you used to start the installation process.

Close the setup application.
Log out from the computer.
Log in to the computer.
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Restart the setup application.

"Previous version detected but no database available"

When you start the setup application, the following message appears, and the setup application stops: ""Previous version detected but no
database available.""

Possible solution

The registry keys that identify your BlackBerry Configuration Database must exist in the Registry Editor.
1. On the server that hosts the BlackBerry Professional Software, open the Registry Editor. On the taskbar, click Start > Run. Type
regedit.
2. Inthe left pane, navigate to HKEY_LOCAL_MACHINE\Research In Motion\BlackBerry Professional Software\Database.
3. Create the following case-sensitive String values (if they do not exist):
» DatabaseName: Type the name of the BlackBerry Configuration Database.
« DatabaseServerMachineName: Type the computer name of the database server.

4. Restart the setup application.
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The setup application prompts for access to the installation media for
Microsoft .NET Framework Version 1.1

Possible cause

When the BlackBerry® Professional Software setup application installs Microsoft® .NET Framework Version 1.1 SP1 on a computer that
hosts a previously installed version of Microsoft .NET Framework Version 1.1, it prompts you for access to the installation media for
Microsoft .NET Framework Version 1.1.

Possible solution
1. In the BlackBerry Professional Software installation media, double-click the Tools folder.
2. Double-click the netfx.msi file.
3. Complete the instructions on the screen.

The setup application did not prompt you to change or confirm the MAPI profile

Possible solution

You can create and change the MAPI profile manually.

In the BlackBerry® Professional Software installation media, double-click the Tools folder.
Double-click the Fixmapisvc.exe file.

Verify that the mapisvc.inf file is installed at C:\winnt\system32 or C:\windows\system32.
On the taskbar, click Start > BlackBerry Professional Software > Edit MAPI Profile.

Type the Microsoft® Exchange Server name.

Click the Microsoft® Windows® account that is associated with the MAPI profile.

Click OK.

N O s WN =

"Could not open ID file"

When you start the BlackBerry® Professional Software setup application, the following message appears, and the setup application
closes:""Could not open ID file.""

Possible solution

1. If you installed the IBM® Lotus® Domino® server but have not started it yet, start it and stop it.
2. Restart the setup application.

32



Adding user accounts

You create and manage user accounts for the BlackBerry® Professional Software using the BlackBerry Manager.

In the BlackBerry Manager, you can use the Add New Users Wizard to create each user account, or you can create each user account
manually. For information about creating a user account manually, see the BlackBerry Professional Software Administration Guide.

The BlackBerry® Professional Software provides preconfigured IT policies that you can apply when you set up a user account. You can
configure additional IT policy rules in these IT policies or change any settings that are shown in the following table.

IT policy rule Default IT  Basic
policy password

security IT
policy

Device-Only Items policy group

Password Required False True

User Can Disable  True False

Password

Maximum Security — 30 min.

Timeout

Maximum Password — 60 days

Age

User Can Change  True True

Timeout

Password Pattern 0 0

Checks

Enable Long-term  — -
Timeout

Password policy group

Maximum Password — -
History

Security policy group

Disallow Third Party — —
Application

Download

Force Lock When - -
Holstered

Medium Medium

password password

security IT security

policy (disallow
application
download) IT
policy

True True

False False

10 min. 10 min.

30 days 30 days

True True

Advanced security Advanced security

IT policy (disallow
application
downloads) IT
policy

True True
False False
10 min. 10 min.
30 days 30 days
True True

atleast1alphaand at least1alpha and atleast1alpha and 1 at least 1alpha and 1

1 numeric

character

True True
6 6

- True
True True

1 numeric character numeric character

numeric character

True True
6 6

True True
True True



Default IT
policy

IT policy rule

Content Protection —
Strength

Disable USB Mass —
Storage

External File System —
Encryption level

Bluetooth policy group
Disable Serial Port —
Profile

Disable Discoverable —
Mode

Disable Address —
Book Transfer

Disable File Transfer —
Require LED —
Connection Indicator
WLAN policy group
WLAN Allow —
Handheld Changes

Basic
password
security IT

policy

False

Medium
password
security IT

policy

True

False

Medium
password
security
(disallow
application
download) IT
policy

True

False

Advanced security
IT policy

Strong

True

Encrypt to user
password (excluding
multimedia
directories)

True

True

True

True

True

False

Advanced security
(disallow
application
downloads) IT
policy

Strong

True

Encrypt to user
password (excluding
multimedia
directories)

True

True

True

True

True

False

You must set up user accounts on your messaging server before you set up user accounts in the BlackBerry® Professional Software.

When you create a user account, you can assign an IT policy to control settings for the account. You can select one of the preconfigured
IT policies, or create your own and select it. For more information about the IT policy rule settings, see the Policy Reference Guide.

Click Select.
Click OK.
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On the Select IT policy screen, specify the IT policy setting for the user account.

On the server that hosts the BlackBerry Professional Software, on the taskbar, click Start > BlackBerry Manager.
In the BlackBerry Manager, click the Home tab.

In the Account section, click Add New Users Wizard.
In the user list, click the name of the user whose BlackBerry Professional Software user account you want to create.



8. On the Device Deployment screen, specify how to activate the BlackBerry device.
9. Click Done.
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Legal notice

©2007 Research In Motion Limited. All Rights Reserved. The BlackBerry and RIM families of related marks, images, and symbols are the
exclusive properties of Research In Motion Limited. RIM, Research In Motion, BlackBerry, "Always On, Always Connected" and the "envelope
in motion" symbol are registered with the U.S. Patent and Trademark Office and may be pending or registered in other countries.

Adobe, Acrobat, and Reader are trademarks of Adobe Systems Incorporated. Apache Tomcat™ is a trademark of the Apache Software
Foundation. Intel and Pentium are trademarks of Intel Corporation. IBM, Domino, Lotus, and Lotus Notes are trademarks of International
Business Machines Corporation. Microsoft, Active Directory, Internet Explorer, Outlook, and SQL Server are trademarks of Microsoft Inc.
Java and JavaScript are trademarks of Sun Microsystems, Inc. VMware is a trademark of VMware Inc. All other brands, product names,
company names, trademarks, and service marks are the properties of their respective owners.

The BlackBerry device and/or associated software are protected by copyright, international treaties, and various patents, including one
or more of the following U.S. patents: 6,278,442; 6,271,605; 6,219,694; 6,075,470; 6,073,318; D445,428; D433,460; D416,256. Other
patents are registered or pending in various countries around the world. Visit www.rim.com/patents for a list of RIM (as hereinafter defined)
patents.

This document is provided "as is" and Research In Motion Limited and its affiliated companies ("RIM") assume no responsibility for any
typographical, technical, or other inaccuracies in this document. In order to protect RIM proprietary and confidential information and/or
trade secrets, this document may describe some aspects of RIM technology in generalized terms. RIM reserves the right to periodically
change information that is contained in this document; however, RIM makes no commitment to provide any such changes, updates,
enhancements, or other additions to this document to you in a timely manner or at all. RIM MAKES NO REPRESENTATIONS, WARRANTIES,
CONDITIONS, OR COVENANTS, EITHER EXPRESS OR IMPLIED (INCLUDING WITHOUT LIMITATION, ANY EXPRESS OR IMPLIED
WARRANTIES OR CONDITIONS OF FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, MERCHANTABILITY, DURABILITY,
TITLE, OR RELATED TO THE PERFORMANCE OR NON-PERFORMANCE OF ANY SOFTWARE REFERENCED HEREIN OR PERFORMANCE
OF ANY SERVICES REFERENCED HEREIN). IN CONNECTION WITH YOUR USE OF THIS DOCUMENTATION, NEITHER RIM NOR ITS
RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES, OR CONSULTANTS SHALL BE LIABLE TO YOU FOR ANY DAMAGES WHATSOEVER
BE THEY DIRECT, ECONOMIC, COMMERCIAL, SPECIAL, CONSEQUENTIAL, INCIDENTAL, EXEMPLARY, OR INDIRECT DAMAGES, EVEN
IF RIM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, INCLUDING WITHOUT LIMITATION, LOSS OF BUSINESS
REVENUE OR EARNINGS, LOST DATA, DAMAGES CAUSED BY DELAYS, LOST PROFITS, OR A FAILURE TO REALIZE EXPECTED SAVINGS.

This document might contain references to third-party sources of information, hardware or software, products or services and/or third-
party web sites (collectively the "Third-Party Information"). RIM does not control, and is not responsible for, any Third-Party Information,
including, without limitation the content, accuracy, copyright compliance, compatibility, performance, trustworthiness, legality, decency,
links, or any other aspect of Third-Party Information. The inclusion of Third-Party Information in this document does not imply endorsement
by RIM of the Third-Party Information or the third party in any way. Installation and use of Third-Party Information with RIM's products
and services may require one or more patent, trademark, or copyright licenses in order to avoid infringement of the intellectual property
rights of others. Any dealings with Third-Party Information, including, without limitation, compliance with applicable licenses and terms
and conditions, are solely between you and the third party. You are solely responsible for determining whether such third-party licenses
are required and are responsible for acquiring any such licenses relating to Third-Party Information. To the extent that such intellectual
property licenses may be required, RIM expressly recommends thatyou do notinstall or use Third-Party Information until all such applicable
licenses have been acquired by you or on your behalf. Your use of Third-Party Information shall be governed by and subject to you agreeing
to the terms of the Third-Party Information licenses. Any Third-Party Information that is provided with RIM's products and services is
provided "as is". RIM makes no representation, warranty or guarantee whatsoever in relation to the Third-Party Information and RIM
assumes no liability whatsoever in relation to the Third-Party Information even if RIM has been advised of the possibility of such damages
or can anticipate such damages.
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